Bug Stomp

Upgrades and changes sometimes have unpredictable results, so post your bugs and glitches in here and I'll get out my trusty wrench and get to fixin'!

8420 - 8434 of 8462


NEW 5 months ago #8420

Everything, it happens sometimes with gotos. It will always happen if there's a goto pointing to another goto (even with the secondary goto being in another reponse, I think); sometimes it happens on other gotos, though, and I'm not 100% sure why. It's never happened on any of my more complex series of gotos for me, so I've always sorted it by just duplicating the goto'd branch and using gotos from the seeks instead.


NEW 4 months ago #8421

it is fixed I had the wrong emotion set for it lol


NEW 4 months ago #8422

I've been trying to talk to tessy, keep getting a "request failed" and losing progress. Anyone know what's up with that?


NEW 4 months ago #8423

keyphrases trigger for me and not for people talking to lilaith x


NEW 4 months ago #8424

RRRRRRRRREEEEEEEEEEEEEEEEEEEEEEEEEEEEEE


NEW 4 months ago #8425

Bobstack, do they trigger if you chat without being logged in? I suspect you've got similar issues to the ones I had - bad initalization of memories. Might be one or two places where you've typoed the memory name, but niitialization is my suspicion.


NEW 4 months ago #8426

what do you mean by initialization?


NEW 4 months ago #8427

I mean the area in the settings - or the top of the file - where you initialize memories. Settings page, about halfway down, AIScript initialization. Stuff like def "21" as "playedAge" or similar; I'd been working offline and using escape chars on the initialization, so def \"21\" as \"playedAge\", for example, which doesn't work in that segment, though it works for the rest (but is optional these days). That being wrong would lead to the AIScript being fine for you if you've been running through other stuff that would set it, or had it remembered from before anything broke, but broken for new or not logged in people, and if AIScript isn't set, it won't trigger responses.


NEW 4 months ago #8428

I agree with Mary - every time I run into that, it's a memory issue. Mine normally aren't because of initialization, though. Sometimes I change a memory how a memory works in some places but miss a few spots. It still works for me because I have the old memories, but other people don't so it doesn't work for them.

If it's not a memory issue, all I can think of is the emotion level.


NEW 4 months ago #8429

i use scripts but i have nothing in ai script initialization.
because i only require temporary memory for lilaith x.


NEW 4 months ago #8430

If people aren't setting memories before you're referencing them, then the seeks will be skipped, regardless of if it's self or temp memories; it might help to add defaults in case that's happening, so you can see for debugging if nothing else. Is it seeks with memories referenced in the responses that are failing, or with aiscript? Is there any emotion range needed for the failing seeks?


NEW 3 months ago #8431

KILL ME


NEW 3 months ago #8432

I use time scripts a lot.
how would I set those up in initialization?


NEW 3 months ago #8433

oof


NEW 3 months ago #8434

for shyla grey time based responses have stopped working.
could you fix that?


Posts 8420 - 8434 of 8462

» More new posts: Seasons