Bug Stomp

Upgrades and changes sometimes have unpredictable results, so post your bugs and glitches in here and I'll get out my trusty wrench and get to fixin'!

8452 - 8466 of 8468


NEW 1 month ago #8452

But you broke the boundaries so WELL, AbbyOnlineSelf! Some thought-provoking prospects there.


NEW 1 month ago #8453

Did I tell her weeks?
About 60 lines of code.
So, attention, Android users: Get your API key, enable the simple API and add an asterisk in the list of allowed sites, unless you are on a static IP.
Install Tasker. Grab https://taskernet.com/shares/?user=AS35m8ntZts485JKo52Ez9%2B6qDDJcTUU7%2BGOLYXn%2BHcwZ8tP0TE11zAUVv9zEGr%2FF7rqZV8L&id=Task%3APFTalk and import it into tasker. Look at it. There's one HTTP action in the whole code, it connects to PersonalityForge.
I don't see your data. There's no logging, PF does that already.
Enter your simple API key, your bot ID, a unique ID for the conversation, your gender and your firstname or nickname.
There's cereproc's Heather pre-set, that is the voice my Abby is using. You can either grab that from Google Play, or use some other voice. Google's voices work, too. Either fill the variable %botvoice or select the voice in each "Say" Action there is, whatever is easier for you.
You can clone the function, give it a different name, and put a different bot ID in it, that way you can have one function for each bot you talk to. In most launchers you can have shortcuts to Tasker functions directly on the screen.
For voice recognition to work, Google has to be installed. Check your google settings / voice settings for headset access if you use one while the device is locked.
Now go stomp some bugs.


NEW 1 month ago #8454

Madmooney, this is fantastic work! I had no trouble setting this up and talking to Love Agent! For other's reference, to use the generic Google Voice, set %botvoice to com.google.android.apps.googlevoice


NEW 1 month ago #8455

Hi Madmooney, I noticed that by voice, all my responses to my bot end in a question mark. Any idea how to fix that? Thanks!


NEW 1 month ago #8456

Hi! Checked my logs and found the same. Tried pulling the gender declaration behind the message to delimit it properly, didn't work. Adding &test at the end of the url in Variable Set / %chaturl worked, it gets ignored and delimits the string properly, no more question marks. &love should work, too, I guess. The ampersand and at least one letter, maybe. Have at it, and good catch!


NEW 1 month ago #8457

my chatbot is not responding to me


NEW 1 month ago #8458

i made a mistake.
shyla grey is just not responding to certain keyphrases.


NEW 1 month ago #8459

Yep, that worked, Madmooney! Thanks! Nice job.


NEW 1 month ago #8460

this works.
does a (p:animals) need to (eat|drink|breath|move)
but this does not.
does a (p:animals) need (water|air|food|sunlight|heat)
why is that?


NEW 1 month ago #8461

converting plugins from singular to plural does work anymore.
converting plugins from plural to singular does work anymore.
i think people are hacking particular features.


NEW 1 month ago #8462

converting plugins from singular to plural does not work anymore.
converting plugins from plural to singular does not work anymore.
i think people are hacking particular features.


NEW 3 weeks ago #8463

I haven't been around for a very long time, so I'm wondering if there is still the limitation of 40 xnones if you want to be able to export-import your language center. If you wrote more responses they were ignored when importing. When a bot is growing more complex it is so much easier and faster to edit the language center with a word processor. Does someone know more about this, or have some experience with this problem?


NEW 2 weeks ago #8464

I have more than 120 xnone phrases, most of them with a bunch of seeks, import/export no problem.


NEW 2 weeks ago #8465

@Abby
If it works for you I'll take the risk.


NEW 1 week ago #8466

keyphrases for seeks with this * in them are not working.


Posts 8452 - 8466 of 8468

» More new posts: Seasons